GLIBC Version Error with Airflow installation (Alexis One-Click Anomaly Detection)

I get the an error when running ./ALEXISGetMACID. Looks like it needs GLIBC 2.25, while we have GLIBC 2.17. Based on a quick search, installing GLIBC 2.25 may not be trivial and may break things (and a simple yum update does not work either).

Problem Statement

I get the following error when running ./ALEXISGetMACID. Looks like it needs GLIBC 2.25, while we have GLIBC 2.17. Based on a quick search, installing GLIBC 2.25 may not be trivial and may break things (and a simple yum update does not work either). So before I attempt to go down that path I want to check in and see if you have a binary version that relies on 2.17, or a simple fix?


Error: 

[22886] Error loading Python lib '/home/gk-k28346/ALEXISGetMACID/libpython3.7m.so.1.0': dlopen: /lib64/libc.so.6: version `GLIBC_2.25' not found (required by /home/gk-k28346/ALEXISGetMACID/libpython3.7m.so.1.0) 

Solution: 

  1. Before starting an AWS EC2 Linux instance check if it has Glibc version 2.26.
  2. Terminal command to know the AWS EC2 Linux instance Glibc instance after starting
    1.  [How to get glibc version - C Lang]: ldd --version